POV-Ray : Documentation : Index
  POV-Ray 3.6 Documentation Online View  
#break
2.2.2.6.3 The #switch, #case, #range and #break Directives
#case
2.2.2.6.3 The #switch, #case, #range and #break Directives
#debug
2.2.2.7.1 Text Message Streams
#declare
2.2.2.2.1 Declaring identifiers
#default
2.2.2.4 The #default Directive
#else
2.2.2.6.1 The #if...#else...#end Directives
#end
2.2.2.6.1 The #if...#else...#end Directives
#error
2.2.2.7.1 Text Message Streams
#fclose
2.2.2.3.2 The #fclose Directive
#fopen
2.2.2.3.1 The #fopen Directive
#if
2.2.2.6.1 The #if...#else...#end Directives
#ifdef
2.2.2.6.2 The #ifdef and #ifndef Directives
#ifndef
2.2.2.6.2 The #ifdef and #ifndef Directives
#include
2.2.2.1 Include Files and the #include Directive
#local
2.2.2.2 The #declare and #local Directives
#macro
2.2.2.8 User Defined Macros
#range
2.2.2.6.3 The #switch, #case, #range and #break Directives
#read
2.2.2.3.3 The #read Directive
#render
2.2.2.7.1 Text Message Streams
#statistics
2.2.2.7.1 Text Message Streams
#switch
2.2.2.6.3 The #switch, #case, #range and #break Directives
#undef
2.2.2.2.4 Destroying Identifiers with #undef
#version
2.2.2.5 The #version Directive
#warning
2.2.2.7.1 Text Message Streams
#while
2.2.2.6.4 The #while...#end Directive
#write
2.2.2.3.4 The #write Directive
+a
2.1.2.8.4 Anti-Aliasing Options
+am
2.1.2.8.4 Anti-Aliasing Options
+b
2.1.2.4.3 Output File Buffer
+c
2.1.2.2.4 Resuming Options
+d
2.1.2.3.1 Display Hardware Settings
+ec
2.1.2.2.2 Partial Output Options
+ef
2.1.2.1.3 Subsets of Animation Frames
+ep
2.1.2.3.4 Mosaic Preview
+er
2.1.2.2.2 Partial Output Options
+f
2.1.2.4.1 Output File Type
+fc
2.1.2.4.1 Output File Type
+fn
2.1.2.4.1 Output File Type
+fp
2.1.2.4.1 Output File Type
+fs
2.1.2.4.1 Output File Type
+ft
2.1.2.4.1 Output File Type
+ga
2.1.2.7.2 Console Text Output
+gd
2.1.2.7.2 Console Text Output
+gf
2.1.2.7.2 Console Text Output
+gi
2.1.2.2.4 Resuming Options
+gr
2.1.2.7.2 Console Text Output
+gs
2.1.2.7.2 Console Text Output
+gw
2.1.2.7.2 Console Text Output
+h
2.1.2.2.1 Height and Width of Output
+hi
2.1.2.5.3 Include File Name
+hn
2.1.2.4.6 File Name
+hs
2.1.2.4.7 Grid Size
+ht
2.1.2.4.5 File Type
+htc
2.1.2.4.5 File Type
+htn
2.1.2.4.5 File Type
+htp
2.1.2.4.5 File Type
+hts
2.1.2.4.5 File Type
+htt
2.1.2.4.5 File Type
+htx
2.1.2.4.5 File Type
+i
2.1.2.5.2 Input File Name
+j
2.1.2.8.4 Anti-Aliasing Options
+k
2.1.2.1.1 External Animation Loop
+kc
2.1.2.1.4 Cyclic Animation
+kff
2.1.2.1.2 Internal Animation Loop
+kfi
2.1.2.1.2 Internal Animation Loop
+ki
2.1.2.1.2 Internal Animation Loop
+l
2.1.2.5.4 Library Paths
+mb
2.1.2.8.2 Automatic Bounding Control
+mv
2.1.2.5.5 Language Version
+o
2.1.2.4.2 Output File Name
+p
2.1.2.3.3 Display Related Settings
+q
2.1.2.8.1 Quality Settings
+r
2.1.2.8.4 Anti-Aliasing Options
+sc
2.1.2.2.2 Partial Output Options
+sf
2.1.2.1.3 Subsets of Animation Frames
+sp
2.1.2.3.4 Mosaic Preview
+sr
2.1.2.2.2 Partial Output Options
+su
2.1.2.8.3 Removing User Bounding
+ua
2.1.2.4.1 Output File Type
+ud
2.1.2.3.3 Display Related Settings
+uf
2.1.2.1.5 Field Rendering
+ul
2.1.2.8.2 Automatic Bounding Control
+uo
2.1.2.1.5 Field Rendering
+ur
2.1.2.8.3 Removing User Bounding
+uv
2.1.2.8.2 Automatic Bounding Control
+v
2.1.2.3.3 Display Related Settings
+w
2.1.2.2.1 Height and Width of Output
+wl
2.1.2.7.4 Warning Level
+x
2.1.2.2.3 Interrupting Options
-a
2.1.2.8.4 Anti-Aliasing Options
-b
2.1.2.4.3 Output File Buffer
-c
2.1.2.2.4 Resuming Options
-d
2.1.2.3.1 Display Hardware Settings
-f
2.1.2.4.1 Output File Type
-ga
2.1.2.7.2 Console Text Output
-gd
2.1.2.7.2 Console Text Output
-gf
2.1.2.7.2 Console Text Output
-gr
2.1.2.7.2 Console Text Output
-gs
2.1.2.7.2 Console Text Output
-gw
2.1.2.7.2 Console Text Output
-h
2.1.2.7.5 Help Screen Switches
-j
2.1.2.8.4 Anti-Aliasing Options
-kc
2.1.2.1.4 Cyclic Animation
-mb
2.1.2.8.2 Automatic Bounding Control
-p
2.1.2.3.3 Display Related Settings
-su
2.1.2.8.3 Removing User Bounding
-ua
2.1.2.4.1 Output File Type
-ud
2.1.2.3.3 Display Related Settings
-uf
2.1.2.1.5 Field Rendering
-ul
2.1.2.8.2 Automatic Bounding Control
-uo
2.1.2.1.5 Field Rendering
-ur
2.1.2.8.3 Removing User Bounding
-uv
2.1.2.8.2 Automatic Bounding Control
-v
2.1.2.3.3 Display Related Settings
-x
2.1.2.2.3 Interrupting Options
aa_level
2.6.2.2 Sampling Parameters & Methods
aa_threshold
2.6.2.2 Sampling Parameters & Methods
abs
2.2.1.3.4 Functions
absorption
2.6.2.1.3 Scattering
accuracy
2.4.4 Isosurface Object
acos
2.2.1.3.4 Functions
acosd
2.7.9.1 Float functions and macros
acosh
2.2.1.3.4 Functions
adaptive
2.4.7.5 Area Lights
adc_bailout
2.3.3.1 ADC_Bailout
Adding New Resolutions
3.3.2 Adding New Resolutions
adj_range
2.7.9.1 Float functions and macros
adj_range2
2.7.9.1 Float functions and macros
agate
2.5.11.1 Agate
agate_turb
2.5.12 Pattern Modifiers
Align_Object
2.7.12.1 shapes.inc
Align_Trans
2.7.18 transforms.inc
all
2.5.1.5.2 The Filter and Transmit Bitmap Modifiers
All_Console
All_File
all_intersections
2.4.4 Isosurface Object
alpha
2.5.1.5.2 The Filter and Transmit Bitmap Modifiers
altitude
2.5.11.30 Slope
always_sample
2.3.4.2.2 always_sample
Ambient
2.5.3 Finish
ambient_light
2.3.3.2 Ambient_Light
angle
2.3.1.1.3 Angles
Animation
Antialias
Antialias_Depth
Antialias_Threshold
aperture
2.3.1.3 Focal Blur
append
2.2.2.3.1 The #fopen Directive
arc_angle
2.3.2.5 Rainbow
Area Light Source
area_light
2.4.7.5 Area Lights
Array
2.2.1.8 Array Identifiers
arrays
asc
2.2.1.3.4 Functions
ascii
2.3.3.6 Charset
asin
2.2.1.3.4 Functions
asind
2.7.9.1 Float functions and macros
asinh
2.2.1.3.4 Functions
assumed_gamma
2.3.3.3 Assumed_Gamma
atan
2.4.1.6 Julia Fractal
atan2
2.2.1.3.4 Functions
atan2d
2.7.9.1 Float functions and macros
atanh
2.2.1.3.4 Functions
atmosphere
2.6.2 Media
Atmospheric Effects
auto-reload
3.5.5.12 Auto-Reload
autostop
2.6.3.2.1 Photon Global Settings
average
2.5.11.2 Average
Axial_Scale_Trans
2.7.18 transforms.inc
Axis_Rotate_Trans
2.7.18 transforms.inc
b_spline
2.4.1.10 Sphere Sweep
Background
2.3.2.2 Background
benchmark
Bevelled_Text
2.7.12.1 shapes.inc
bezier
2.4.2.1 Bicubic Patch
Bezier Patch
2.4.2.1 Bicubic Patch
bezier_spline
2.4.1.7 Lathe
bicubic_patch
2.4.2.1 Bicubic Patch
Bits_Per_Color
black spots
1.4.2.5 Why are there strange dark pixels or noise on my CSG object?
black_hole
2.5.12.6.1 Black Hole Warp
blob
2.4.1.1 Blob
Blob Constructs
Blobs
2.4.1.1 Blob
blue
2.2.1.5.2 Color Keywords
Blur
2.3.1.3 Focal Blur
blur_samples
2.3.1.3 Focal Blur
BMP files
3.1.5.1 SYS File Type
BMP output
2.1.2.4.1 Output File Type
boolean
2.2.1.3.5 Built-in Constants
bounded_by
2.4.9.2 Bounded_By
Bounding
Bounding_Threshold
box
2.4.1.2 Box
boxed
2.5.11.3 Boxed
bozo
2.5.11.4 Bozo
break
2.2.2.6.3 The #switch, #case, #range and #break Directives
brick
2.5.11.5 Brick
brick_size
2.5.12 Pattern Modifiers
brightness
2.3.4.2.3 brightness
brilliance
2.5.3.2.2 Brilliance
Buffer_Output
2.1.2.4.3 Output File Buffer
Buffer_Size
2.1.2.4.3 Output File Buffer
Bug Reports
3.6 Bug Reports in Windows specific
5.7 Bug Reports in Unix specific
bump_map
2.5.2.3 Bump Maps
bump_size
2.5.2.3.2 Bump_Size
Bumpiness
bumps
2.5.11.6 Bumps
Camera
2.3.1 Camera
case
2.2.2.6.3 The #switch, #case, #range and #break Directives
caustics
2.6.1.7 Simulated Caustics
ceil
2.2.1.3.4 Functions
cells
2.5.11.7 Cells
Center_Object
2.7.12.1 shapes.inc
Center_Trans
2.7.18 transforms.inc
charset
checker
2.5.11.8 Checker
checking for new versions
3.5.8.8 Check For New Versions
chr
2.2.1.7.3 String Functions
CHSL2RGB
2.7.3.2 Color macros
CHSV2RGB
2.7.3.2 Color macros
Circle_Text
2.7.12.1 shapes.inc
circular
2.4.7.5 Area Lights
citations
1.5.2 Citing POV-Ray in Academic Publications
clamp
2.7.9.1 Float functions and macros
Clear Queue
3.5.7.7 Clear Queue
clip
2.7.9.1 Float functions and macros
clipped_by
2.4.9.1 Clipped_By
Clock
2.2.1.3.6 Built-in Variables
clock_delta
2.2.1.3.6 Built-in Variables
clock_on
2.2.1.3.6 Built-in Variables
Close File
3.5.1.3 Close
Clouds
CodeList
3.2.6.5 Keyword Expansion and CodeList
collect
2.6.3.2.2 Shooting Photons at an Object
Color
2.2.1.5 Specifying Colors
Color List Pigments
Color Maps
1.2.5.3 Creating Color Patterns
Color Patterns
color_map
2.5.1.3 Color Maps
colors
colour
2.2.1.5 Specifying Colors
colour_map
2.5.1.3 Color Maps
Command-Line
Command-line dialog
3.5.7.1 Edit Settings/Render
Command-line Options
1.2.8 Setting POV-Ray Options
comment
2.2.1.2 Comments
component
2.4.1.1 Blob
composite
2.4.6.2 Union
concat
2.2.1.7.3 String Functions
conditional directives
cone
2.4.1.3 Cone
confidence
2.3.1.3 Focal Blur
conic_sweep
2.4.1.8 Prism
Connect_Spheres
2.7.12.1 shapes.inc
conserve_energy
2.5.3.5 Conserve Energy for Reflection
constant fog
2.3.2.3 Fog
Constructive Solid Geometry
1.2.3 CSG Objects
contained_by
2.4.4 Isosurface Object
contents
Context Menus
3.5.10 Context Menus
Continue_Trace
control0
2.5.12 Pattern Modifiers
control1
2.5.12 Pattern Modifiers
Convert_Color
2.7.3.2 Color macros
Coordinate System
coords
2.5.11.13 Facets
cos
2.2.1.3.4 Functions
cosd
2.7.9.1 Float functions and macros
cosh
2.2.1.3.4 Functions
count
2.3.4.2.4 count
crackle
2.5.11.9 Crackle Patterns
crand
2.5.3.2.3 Crand Graininess
Create_Ini
CRGB2HSL
2.7.3.2 Color macros
CRGB2HSV
2.7.3.2 Color macros
CRGBStr
2.7.16 strings.inc
Cross Section Type
2.7.7.1 Common Parameters
CSG
2.4.6 Constructive Solid Geometry
cube
2.4.1.6 Julia Fractal
cubic
2.4.3.2 Poly, Cubic and Quartic
cubic_spline
2.4.1.7 Lathe
cubic_wave
2.5.12 Pattern Modifiers
cutaway_textures
2.5.10 Cutaway Textures
Cyclic_Animation
2.1.2.1.4 Cyclic Animation
cylinder
2.4.1.4 Cylinder
cylindrical
2.5.11.10 Cylindrical
Cylindrical Light Source
debug
2.2.2.7.1 Text Message Streams
Debug_Console
Debug_File
Declare
2.2.2.2.1 Declaring identifiers
Declaring
default
2.2.2.4 The #default Directive
Default Output Directory
2.1.2.4.2 Output File Name
default texture
Default values
defined
2.2.1.3.4 Functions
degrees
2.2.1.3.4 Functions
demonstration
Demonstration render
3.2.1 The Demo
density
density_file
2.5.11.11 Density_File
density_map
2.6.2.3.3 Density Maps and Density Lists
dents
2.5.11.12 Dents
Depth of field
2.3.1.3 Focal Blur
df3
2.5.11.11 Density_File
Difference
2.4.6.4 Difference
diffuse
dimension_size
2.2.1.3.4 Functions
dimensions
2.2.1.3.4 Functions
direction
2.3.1.1.4 The Direction Vector
Directives
Directory
disc
2.4.2.2 Disc
dispersion
2.6.1.5 Dispersion
dispersion_samples
2.6.1.5 Dispersion
Display
Display_Gamma
2.1.2.3.1 Display Hardware Settings
dist_exp
2.5.12.6.5 Mapping using warps
distance
2.3.2.3 Fog
div
2.2.1.3.4 Functions
Divergence
2.7.9.3 Vector Analysis
double_illuminate
2.4.9.8 Double_Illuminate
drag and drop
3.2.3 Dragging and Dropping Files
Draw_Vistas
dropping files
3.2.3 Dragging and Dropping Files
dynamic max_gradient
2.4.4 Isosurface Object
eccentricity
2.6.2.1.3 Scattering
Edit Menu
3.5.2 Edit Menu
Editor
3.2.6 Using the Internal Editor
Editor Menu
3.5.5 Editor Menu
Editor Window
3.4.6 The Editor Window
else
2.2.2.6.1 The #if...#else...#end Directives
emission
2.6.2.1.2 Emission
end
2.2.2.6.1 The #if...#else...#end Directives
End_Column
End_Row
2.1.2.2.2 Partial Output Options
Environment variables
error
2.2.2.7.1 Text Message Streams
error_bound
2.3.4.2.11 nearest_count
eval_pigment
2.7.7.3 Pre defined functions
evaluate
2.4.4 Isosurface Object
even
2.7.9.1 Float functions and macros
exp
2.2.1.3.4 Functions
expand_thresholds
2.6.3.5.2 Adaptive Search Radius
exponent
2.5.3.4 Specular Reflection
Expressions
Extents
2.7.12.1 shapes.inc
exterior
2.5.11.14 Fractal Patterns
extinction
2.6.2.1.3 Scattering
f_algbr_cyl1
2.7.7.2 Internal Functions
f_algbr_cyl2
2.7.7.2 Internal Functions
f_algbr_cyl3
2.7.7.2 Internal Functions
f_algbr_cyl4
2.7.7.2 Internal Functions
f_bicorn
2.7.7.2 Internal Functions
f_bifolia
2.7.7.2 Internal Functions
f_blob
2.7.7.2 Internal Functions
f_blob2
2.7.7.2 Internal Functions
f_boy_surface
2.7.7.2 Internal Functions
f_comma
2.7.7.2 Internal Functions
f_cross_ellipsoids
2.7.7.2 Internal Functions
f_crossed_trough
2.7.7.2 Internal Functions
f_cubic_saddle
2.7.7.2 Internal Functions
f_cushion
2.7.7.2 Internal Functions
f_devils_curve
2.7.7.2 Internal Functions
f_devils_curve_2d
2.7.7.2 Internal Functions
f_dupin_cyclid
2.7.7.2 Internal Functions
f_ellipsoid
2.7.7.2 Internal Functions
f_enneper
2.7.7.2 Internal Functions
f_flange_cover
2.7.7.2 Internal Functions
f_folium_surface
2.7.7.2 Internal Functions
f_folium_surface_2d
2.7.7.2 Internal Functions
f_glob
2.7.7.2 Internal Functions
f_heart
2.7.7.2 Internal Functions
f_helical_torus
2.7.7.2 Internal Functions
f_helix1
2.7.7.2 Internal Functions
f_helix2
2.7.7.2 Internal Functions
f_hetero_mf
2.7.7.2 Internal Functions
f_hex_x
2.7.7.2 Internal Functions
f_hex_y
2.7.7.2 Internal Functions
f_hunt_surface
2.7.7.2 Internal Functions
f_hyperbolic_torus
2.7.7.2 Internal Functions
f_isect_ellipsoids
2.7.7.2 Internal Functions
f_kampyle_of_eudoxus
2.7.7.2 Internal Functions
f_kampyle_of_eudoxus_2d
2.7.7.2 Internal Functions
f_klein_bottle
2.7.7.2 Internal Functions
f_kummer_surface_v1
2.7.7.2 Internal Functions
f_kummer_surface_v2
2.7.7.2 Internal Functions
f_lemniscate_of_gerono
2.7.7.2 Internal Functions
f_lemniscate_of_gerono_2d
2.7.7.2 Internal Functions
f_mesh1
2.7.7.2 Internal Functions
f_mitre
2.7.7.2 Internal Functions
f_nodal_cubic
2.7.7.2 Internal Functions
f_noise3d
2.7.7.2 Internal Functions
f_noise_generator
2.7.7.2 Internal Functions
f_odd
2.7.7.2 Internal Functions
f_ovals_of_cassini
2.7.7.2 Internal Functions
f_parabolic_torus
2.7.7.2 Internal Functions
f_paraboloid
2.7.7.2 Internal Functions
f_ph
2.7.7.2 Internal Functions
f_pillow
2.7.7.2 Internal Functions
f_piriform
2.7.7.2 Internal Functions
f_piriform_2d
2.7.7.2 Internal Functions
f_poly4
2.7.7.2 Internal Functions
f_polytubes
2.7.7.2 Internal Functions
f_quantum
2.7.7.2 Internal Functions
f_quartic_cylinder
2.7.7.2 Internal Functions
f_quartic_paraboloid
2.7.7.2 Internal Functions
f_quartic_saddle
2.7.7.2 Internal Functions
f_r
2.7.7.2 Internal Functions
f_ridge
2.7.7.2 Internal Functions
f_ridged_mf
2.7.7.2 Internal Functions
f_rounded_box
2.7.7.2 Internal Functions
f_scallop_wave
2.7.7.3 Pre defined functions
f_sine_wave
2.7.7.3 Pre defined functions
f_snoise3d
2.7.7.3 Pre defined functions
f_sphere
2.7.7.2 Internal Functions
f_spikes
2.7.7.2 Internal Functions
f_spikes_2d
2.7.7.2 Internal Functions
f_spiral
2.7.7.2 Internal Functions
f_sqr
2.7.9.1 Float functions and macros
f_steiners_roman
2.7.7.2 Internal Functions
f_strophoid
2.7.7.2 Internal Functions
f_strophoid_2d
2.7.7.2 Internal Functions
f_superellipsoid
2.7.7.2 Internal Functions
f_th
2.7.7.2 Internal Functions
f_torus
2.7.7.2 Internal Functions
f_torus2
2.7.7.2 Internal Functions
f_torus_gumdrop
2.7.7.2 Internal Functions
f_umbrella
2.7.7.2 Internal Functions
f_witch_of_agnesi
2.7.7.2 Internal Functions
f_witch_of_agnesi_2d
2.7.7.2 Internal Functions
face_indices
2.4.2.4 Mesh2
facets
2.5.11.13 Facets
fade_color
2.6.1.6 Attenuation
fade_colour
2.6.1.6 Attenuation
fade_distance
2.4.7.9 Light Fading
fade_power
2.4.7.9 Light Fading
Fading Light
1.2.4.6.3 Using Light Fading
falloff
2.4.7.2 Spotlights
falloff_angle
2.3.2.5 Rainbow
false
2.2.1.3.5 Built-in Constants
FAQ
1.4 Questions and Tips
Fatal_Console
Fatal_Error_Command
Fatal_Error_Return
2.1.2.6.3 Shell Command Return Actions
Fatal_File
fclose
2.2.2.3.2 The #fclose Directive
Field_Render
2.1.2.1.5 Field Rendering
file i/o
file inclusion
File Menu
3.5.1 File Menu
File Queue
3.5.7.6 File Queue
file_exists
2.2.1.3.4 Functions
filter
2.2.1.5 Specifying Colors
final_clock
2.2.1.3.6 Built-in Variables
final_frame
2.2.1.3.6 Built-in Variables
Finding include files
2.1.2.5.4 Library Paths
finish
2.5.3 Finish
fisheye
2.3.1.2.3 Fisheye projection
flatness
2.4.2.1 Bicubic Patch
flip
2.5.12.6.2 Repeat Warp
Float
float expressions
floats
floor
2.2.1.3.4 Functions
fn_Divergence
2.7.9.3 Vector Analysis
fn_Gradient
2.7.9.3 Vector Analysis
fn_Gradient_Directional
2.7.9.3 Vector Analysis
Focal Blur
focal_point
2.3.1.3 Focal Blur
focus
1.2.6.1 Using Focal Blur
Fog
2.3.2.3 Fog
fog_alt
2.3.2.3 Fog
fog_offset
2.3.2.3 Fog
fog_type
2.3.2.3 Fog
fopen
2.2.2.3.1 The #fopen Directive
form
2.5.11.9 Crackle Patterns
fractal
2.4.1.6 Julia Fractal
Fractal Object
2.4.1.6 Julia Fractal
frame_number
2.2.1.3.6 Built-in Variables
frequency
2.5.12 Pattern Modifiers
fresnel
2.5.3.4 Specular Reflection
function
2.2.1.6 User-Defined Functions
function image
Functions
2.2.1.6 User-Defined Functions
gamma
gather
2.6.3.2.1 Photon Global Settings
GetStats
2.7.9.1 Float functions and macros
gif
2.5.1.5.1 Specifying an Image Map
global settings
global_lights
2.4.8 Light Groups
global_settings
2.3.3 Global Settings
gradient
2.5.11.17 Gradient
Gradient_Directional
2.7.9.3 Vector Analysis
Gradient_Length
2.7.9.3 Vector Analysis
granite
2.5.11.18 Granite
gray
2.2.1.5.4 Color Operators
gray_threshold
2.3.4.2.6 gray_threshold
green
2.2.1.5.2 Color Keywords
Ground Fog
2.3.2.3 Fog
GUI Extensions Menu
3.5.9.5 GUI Extensions Menu
halo
2.5.4 Halo
Height
height_field
2.4.1.5 Height Field
Help On This Menu
3.5.8.10.6 Hide New User Help
Hex_Tiles_Ptrn
2.7.17.7 Texture and pattern macros
hexagon
2.5.11.19 Hexagon
HF_Cylinder
2.7.12.1.1 The HF Macros
hf_gray_16
2.3.3.4 HF_Gray_16
HF_Sphere
2.7.12.1.1 The HF Macros
HF_Square
2.7.12.1.1 The HF Macros
HF_Torus
2.7.12.1.1 The HF Macros
hierarchy
2.4.1.1 Blob
Highlights
1.3.4.3.2 Using Surface Highlights
Histogram
2.7.9.1 Float functions and macros
Histogram_Grid_Size
Histogram_Name
Histogram_Type
hollow
2.4.9.5 Hollow
Hollow Objects
hypercomplex
2.4.1.6 Julia Fractal
I/O Restrictions
3.2.7 I/O Restrictions in Windows specific
5.4 I/O Restrictions in Unix specific
identifier
2.2.1.1 Identifiers and Keywords
Identifiers
2.2.1.1 Identifiers and Keywords
if
2.2.2.6.1 The #if...#else...#end Directives
ifdef
2.2.2.6.2 The #ifdef and #ifndef Directives
iff
2.5.1.5.1 Specifying an Image Map
ifndef
2.2.2.6.2 The #ifdef and #ifndef Directives
image_height
2.2.1.3.6 Built-in Variables
image_map
2.5.1.5 Image Maps
image_pattern
2.5.11.20 Image Pattern
image_width
2.2.1.3.6 Built-in Variables
include
2.2.2.1 Include Files and the #include Directive
Include Files
Include Path
2.1.2.5.4 Library Paths
Include_Header
INI files
3.2.5.2 INI Files
initial_clock
2.2.1.3.6 Built-in Variables
initial_frame
2.2.1.3.6 Built-in Variables
Initialization
Input_File_Name
Insert Menu
3.5.6 Insert Menu
inside
2.2.1.3.4 Functions
inside_vector
2.4.2.3.1 Solid Mesh
int
2.2.1.3.4 Functions
Interference
1.3.4.3.4 Using Iridescence
interior
2.6.1 Interior
interior texture
2.8.9.4 Interior Texture
interior_texture
2.5.9 Interior Texture
internal
2.2.1.6.6 Internal Pre-Defined Functions
Internal Editor
interpolate
2.5.12 Pattern Modifiers
Intersection
2.4.6.3 Intersection
intervals
2.6.2.2 Sampling Parameters & Methods
inverse
2.4.9.4 Inverse
ior
2.6.1.4 Refraction
Irid
2.5.3.6 Iridescence
irid_wavelength
2.3.3.5 Irid_Wavelength
Irregular_Bricks_Ptrn
2.7.17.7 Texture and pattern macros
Isect
2.7.12.1 shapes.inc
isosurface
2.4.4 Isosurface Object
jitter
2.4.7.5 Area Lights
Jitter_Amount
jpeg
2.5.1.5.1 Specifying an Image Map
julia
2.5.11.14 Fractal Patterns
julia_fractal
2.4.1.6 Julia Fractal
Keep Single Instance
3.5.8.1 Keep Single Instance
Keyboard Configuration
3.5.5.15.3 Keyboard
keyword
2.2.1.1 Identifiers and Keywords
Keyword Expansion
3.2.6.5 Keyword Expansion and CodeList
keyword:#include
1.2.1.2 Adding Standard Include Files
keywords
2.2.1.1 Identifiers and Keywords
lambda
2.5.12 Pattern Modifiers
Language
3.5.5.15.2 Language/Tabs
language basics
language directives
lathe
2.4.1.7 Lathe
layered texture
Layered Textures
Left-Handed coordinate system
1.2.1.1 Understanding POV-Ray's Coordinate System
leopard
2.5.11.21 Leopard
Library_Path
License
1.5.1 POV-Ray User License
Light Fading
Light Source
Light Sources
Light_Buffer
light_group
2.4.8 Light Groups
light_source
2.4.7 Light Sources
lightgroup
lights
linear_spline
2.4.1.7 Lathe
linear_sweep
2.4.1.8 Prism
List Textures
Literals
ln
2.2.1.3.4 Functions
load_file
2.3.4.2.15 Save and load radiosity data
local
2.2.2.2 The #declare and #local Directives
location
2.3.1.1.1 Location and Look_At
log
2.2.1.3.4 Functions
look_at
2.3.1.1.1 Location and Look_At
looks_like
low_error_factor
2.3.4.2.7 low_error_factor
macro
2.2.2.8 User Defined Macros
Macros
2.2.2.8 User Defined Macros
magnet
2.5.11.14 Fractal Patterns
Main Window
3.4.1 The Main Window
major_radius
2.5.12.6.5 Mapping using warps
mandel
2.5.11.14 Fractal Patterns
map_type
2.5.12.7.2 The map_type Option
marble
2.5.11.22 Marble
Mark Shuttleworth
3.5.7.10 Duty Cycle
material
2.4.9.3 Material
material_map
2.5.5.3 Material Maps
matrix
2.8.5 Transformations
Matrix_Trans
2.7.18 transforms.inc
max
2.2.1.3.4 Functions
max3
2.7.9.1 Float functions and macros
max_extent
2.2.1.4.5 Functions
max_gradient
2.4.4 Isosurface Object
max_intersections
2.3.3.8 Max_Intersections
max_iteration
2.4.1.6 Julia Fractal
max_sample
2.3.4.2.8 max_sample
max_trace
2.4.4 Isosurface Object
max_trace_level
2.3.3.7 Max_Trace_Level
Mean
2.7.9.1 Float functions and macros
media
2.6.2 Media
media_attenuation
2.4.7.11 Atmospheric Attenuation
media_interaction
2.4.7.10 Atmospheric Media Interaction
Menus
3.5 Menus
Merge
2.4.6.5 Merge
mesh
2.4.2.3 Mesh
mesh2
2.4.2.4 Mesh2
message streams
Message Window
3.4.5 The Message Window
Message Window Menu
3.5.8.10.9 Message Window
Metallic
2.5.3.3.3 Metallic Highlight Modifier
method
2.6.2.2 Sampling Parameters & Methods
metric
2.5.11.9 Crackle Patterns
min
2.2.1.3.4 Functions
min3
2.7.9.1 Float functions and macros
min_extent
2.2.1.4.5 Functions
minimum_reuse
2.3.4.2.10 minimum_reuse
mod
2.2.1.3.4 Functions
mortar
2.5.12 Pattern Modifiers
Mountains
Moving
natural_spline
2.2.1.9 Spline Identifiers
nearest_count
2.3.4.2.11 nearest_count
Negative Strength
New Features
new versions
no
2.2.1.3.5 Built-in Constants
no image
2.4.9.7 No_Image, No_Reflection
no reflection
2.4.9.7 No_Image, No_Reflection
no_bump_scale
2.5.2.4 Scaling normals
no_image
2.4.9.7 No_Image, No_Reflection
no_reflection
2.4.9.7 No_Image, No_Reflection
no_shadow
2.4.9.6 No_Shadow
noise generator
noise_generator
2.5.12 Pattern Modifiers
normal
2.5.2 Normal
Normal Maps
Normal Modifiers
normal_indices
2.4.2.4 Mesh2
normal_map
2.5.2.2 Normal Maps and Normal Lists
normal_vectors
2.4.2.4 Mesh2
Normals
Normals and Radiosity
1.3.7.4 Normals and Radiosity
number_of_waves
2.3.3.9 Number_Of_Waves
Object
2.5.11.23 Object Pattern
Object Lights
1.2.4.6.2 Assigning an Object to a Light Source
object media
2.6.1.8 Object-Media
Object modifiers
objects
2.4 Objects
octaves
2.5.12 Pattern Modifiers
odd
2.7.9.1 Float functions and macros
Odd_Field
2.1.2.1.5 Field Rendering
off
2.2.1.3.5 Built-in Constants
offset
2.5.12.6.2 Repeat Warp
Older Files
3.5.1.8 Older Files
omega
2.5.12 Pattern Modifiers
omnimax
2.3.1.2.5 Omnimax projection
on
2.2.1.3.5 Built-in Constants
On Completion
3.5.7.12 On Completion
once
2.5.12.7.1 The once Option
onion
2.5.11.24 Onion
open
2.6.1 Interior
Operators
Options
Options Menu
3.5.8 Options Menu
orient
2.4.7.5 Area Lights
orientation
2.5.12.6.5 Mapping using warps
orthographic
2.3.1.2.2 Orthographic projection
Output
Output File
Output File Type
output formats
2.1.2.4.1 Output File Type
Output_Alpha
Output_File_Name
Output_File_Type
Output_to_File
2.1.2.4 File Output Options
Palette
panoramic
2.3.1.2.6 Panoramic projection
parallel
2.4.7.4 Parallel Lights
parametric
2.4.5 Parametric Object
Parse_String
2.7.16 strings.inc
pass_through
2.6.3.2.2 Shooting Photons at an Object
Path
pattern
2.2.1.6.3 Declaring User-Defined Float Functions
Pattern modifier
Pattern Modifiers
patterned texture
Patterns
1.2.5.3 Creating Color Patterns
Pause_When_Done
perspective
2.3.1.2.1 Perspective projection
Perturbation
pgm
2.5.1.5.1 Specifying an Image Map
phase
2.5.12 Pattern Modifiers
phong
2.5.3.3.1 Phong Highlights
phong_size
2.5.3.3.1 Phong Highlights
photon
photons
2.6.3.2.1 Photon Global Settings
pi
2.2.1.3.5 Built-in Constants
pigment
2.5.1 Pigment
Pigment and Patterns
Pigment Maps
pigment_map
2.5.1.4 Pigment Maps and Pigment Lists
pigment_pattern
2.5.11.25 Pigment Pattern
Pigments
Pitfalls
plain texture
planar
2.5.11.26 Planar
plane
2.4.3.1 Plane
png
2.5.1.5.1 Specifying an Image Map
PNG output
2.1.2.4.1 Output File Type
point light
point_at
2.4.7.2 Spotlights
Point_At_Trans
2.7.18 transforms.inc
Pointlight Source
poly
2.4.3.2 Poly, Cubic and Quartic
poly_wave
2.5.12 Pattern Modifiers
polygon
2.4.2.5 Polygon
Post_Frame_Command
Post_Frame_Return
2.1.2.6.3 Shell Command Return Actions
Post_Scene_Command
Post_Scene_Return
2.1.2.6.3 Shell Command Return Actions
poster
3.5.7.10 Duty Cycle
pot
2.4.1.5 Height Field
POV-Ray Legal Document
1.5.1 POV-Ray User License
pov-ray license
1.5.1 POV-Ray User License
POVINI environment variable
1.2.8.3 Using the POVINI Environment Variable
POVLEGAL
1.5.1 POV-Ray User License
POVLEGAL.DOC
1.5.1 POV-Ray User License
POVRAYOPT environment variable
1.2.8.3 Using the POVINI Environment Variable
pow
2.2.1.3.4 Functions
ppm
2.5.1.5.1 Specifying an Image Map
PPM output
2.1.2.4.1 Output File Type
Pre_Frame_Command
Pre_Frame_Return
2.1.2.6.3 Shell Command Return Actions
Pre_Scene_Command
Pre_Scene_Return
2.1.2.6.3 Shell Command Return Actions
precision
2.4.1.6 Julia Fractal
precompute
2.4.5 Parametric Object
Preset Rendering Options
3.4.2.1 Preset Rendering Options
pretrace_end
2.3.4.2.13 Pretrace
pretrace_start
2.3.4.2.13 Pretrace
Preview_End_Size
Preview_Start_Size
Priority
prism
2.4.1.8 Prism
prod
2.2.1.6.1 Sum and Product functions
projected_through
2.4.7.8 Projected_Through
projection
pwr
2.4.1.6 Julia Fractal
Quad
2.7.12.1 shapes.inc
quadratic_spline
2.4.1.7 Lathe
quadric
2.4.3.3 Quadric
Quality
quartic
2.4.3.2 Poly, Cubic and Quartic
quaternion
2.4.1.6 Julia Fractal
Questions and Tips
1.4 Questions and Tips
quick_color
2.5.1.6 Quick Color
quick_colour
2.5.1.6 Quick Color
quickref
2.8 Quick Reference
quilted
2.5.11.27 Quilted
radial
2.5.11.28 Radial
radians
2.2.1.3.4 Functions
Radiosity
2.3.4 Radiosity
Radiosity performance considerations
1.3.7.5 Performance considerations
radius
2.4.7.2 Spotlights
Rainbow
2.3.2.5 Rainbow
ramp_wave
2.5.12 Pattern Modifiers
rand
2.2.1.3.4 Functions
Rand_Array_Item
2.7.1 arrays.inc
Rand_Bernoulli
2.7.11.2.3 Discrete Distributions
Rand_Beta
2.7.11.2.2 Continuous Skewed Distributions
Rand_Binomial
2.7.11.2.3 Discrete Distributions
Rand_Cauchy
2.7.11.2.1 Continuous Symmetric Distributions
Rand_Chi_Square
2.7.11.2.2 Continuous Skewed Distributions
Rand_Erlang
2.7.11.2.2 Continuous Skewed Distributions
Rand_Exp
2.7.11.2.2 Continuous Skewed Distributions
Rand_F_Dist
2.7.11.2.2 Continuous Skewed Distributions
Rand_Gamma
2.7.11.2.2 Continuous Skewed Distributions
Rand_Gauss
2.7.11.2.1 Continuous Symmetric Distributions
Rand_Geo
2.7.11.2.3 Discrete Distributions
Rand_Lognormal
2.7.11.2.2 Continuous Skewed Distributions
Rand_Normal
2.7.11.2.1 Continuous Symmetric Distributions
Rand_Pareto
2.7.11.2.2 Continuous Skewed Distributions
Rand_Poisson
2.7.11.2.3 Discrete Distributions
Rand_Spline
2.7.11.2.2 Continuous Skewed Distributions
Rand_Student
2.7.11.2.1 Continuous Symmetric Distributions
Rand_Tri
2.7.11.2.2 Continuous Skewed Distributions
Rand_Weibull
2.7.11.2.2 Continuous Skewed Distributions
range
2.2.2.6.3 The #switch, #case, #range and #break Directives
ratio
2.6.2.2 Sampling Parameters & Methods
Ray-Tracing
Re-display Render Window
3.5.8.10.18 Re-display
reach for the stars
3.5.7.10 Duty Cycle
read
2.2.2.3.3 The #read Directive
reciprocal
2.4.1.6 Julia Fractal
recursion_limit
2.3.4.2.14 recursion_limit
red
2.2.1.5.2 Color Keywords
redirecting stream output
2.1.2.7.3 Directing Text Streams to Files
refelection
reference
1.5.2 Citing POV-Ray in Academic Publications
Reflection
2.5.3.4 Specular Reflection
reflection_exponent
2.5.3.4 Specular Reflection
refraction
2.6.3.2.1 Photon Global Settings
reloading changed files
3.5.5.12 Auto-Reload
Remove_Bounds
render
2.2.2.7.1 Text Message Streams
Render Menu
3.5.7 Render Menu
render priority
3.5.7.9 Render Priority
Render Window
3.4.7 The Render Window
Render Window Menu
3.5.8.10.15 Render Window
Render_Console
Render_File
rendering speed
3.7 Speed Considerations
Reorient_Trans
2.7.18 transforms.inc
repeat
2.5.12.6.2 Repeat Warp
Reporting bugs
3.6 Bug Reports
Rerun
3.5.7.13 Rerun
Rerun Dialog
3.5.7.13.1 Rerun Dialog
Rerun Menu
3.5.7.13 Rerun
Resize_Array
2.7.1 arrays.inc
Resolution
2.1.2.2.1 Height and Width of Output
Resolutions
Restrictions
Reverse_Array
2.7.1 arrays.inc
rgb
2.2.1.5.1 Color Vectors
rgbf
2.2.1.5.1 Color Vectors
rgbft
2.2.1.5.1 Color Vectors
rgbt
2.2.1.5.1 Color Vectors
right
2.3.1.1.5 Up and Right Vectors
Right-Handed coordinate system
1.2.1.1 Understanding POV-Ray's Coordinate System
ripples
2.5.11.29 Ripples
rotate
2.8.5 Transformations
Rotate_Around_Trans
2.7.18 transforms.inc
roughness
2.5.3.3.2 Specular Highlight
Round_Box_Union
2.7.12.1 shapes.inc
Round_Cone2_Union
2.7.12.1 shapes.inc
Round_Cone3_Union
2.7.12.1 shapes.inc
Round_Cone_Union
2.7.12.1 shapes.inc
Round_Cylinder_Union
2.7.12.1 shapes.inc
RRand
2.7.11.1 Flat Distributions
Run Benchmark
3.5.7.5 Run Benchmark
running
samples
2.6.2.2 Sampling Parameters & Methods
Sampling_Method
save_file
2.3.4.2.15 Save and load radiosity data
scale
2.8.5 Transformations
scallop_wave
2.5.12 Pattern Modifiers
scattering
2.6.2.1.3 Scattering
scene
Scene Description Language
2.2 Scene Description Language
Search Menu
3.5.3 Search Menu
Search Path
2.1.2.5.4 Library Paths
Security
seed
2.2.1.3.4 Functions
select
2.2.1.3.4 Functions
Selection Menu
3.5.2.10 Selection
SetGradientAccuracy
2.7.9.3 Vector Analysis
Settings
sgn
2.7.9.1 Float functions and macros
shadowless
2.4.7.6 Shadowless Lights
Shadowless Lights
Shapes
Shear_Trans
2.7.18 transforms.inc
Shuttleworth
sin
2.2.1.3.4 Functions
sind
2.7.9.1 Float functions and macros
sine_wave
2.5.12 Pattern Modifiers
sinh
2.2.1.3.4 Functions
size
2.5.11.13 Facets
Sky
2.3.1.1.2 The Sky Vector
Sky Sphere
sky_sphere
2.3.2.4 Sky Sphere
slice
2.4.1.6 Julia Fractal
slope
2.5.11.30 Slope
slope_map
2.5.2.1 Slope Maps
smooth
2.4.1.5 Height Field
smooth_triangle
2.4.2.6 Triangle and Smooth Triangle
solid
2.5.11.9 Crackle Patterns
solid triangle mesh
2.4.2.3.1 Solid Mesh
sor
2.4.1.12 Surface of Revolution
Sort_Array
2.7.1 arrays.inc
Sort_Compare
2.7.1 arrays.inc
Sort_Partial_Array
2.7.1 arrays.inc
Sort_Swap_Data
2.7.1 arrays.inc
sound
Sounds
3.5.7.11 Sound Settings
spacing
2.6.3.2.1 Photon Global Settings
spacing_multiplier
2.6.3.2.2 Shooting Photons at an Object
Special Textures
specular
2.5.3.3.2 Specular Highlight
speed
3.7 Speed Considerations
sphere
2.4.1.9 Sphere
sphere_sweep
2.4.1.10 Sphere Sweep
spherical
2.5.11.31 Spherical
Spheroid
2.7.12.1 shapes.inc
spiral
2.5.11.32 Spiral1
spiral1
2.5.11.32 Spiral1
spiral2
2.5.11.33 Spiral2
Spline
2.2.1.9 Spline Identifiers
spline_trans
2.7.18 transforms.inc
Splines
split_union
Split_Unions
spotlight
Spotlight Source
spotted
2.5.11.34 Spotted
sqr
2.4.1.6 Julia Fractal
sqrt
2.2.1.3.4 Functions
SRand
2.7.11.1 Flat Distributions
standard benchmark
standard demonstration
Standard Include Files
Star_Ptrn
2.7.17.7 Texture and pattern macros
Start Rendering
3.5.7.3 Start Rendering (Go!)/Stop Rendering
Start_Column
Start_Row
Statistic_Console
Statistic_File
statistics
2.2.2.7.1 Text Message Streams
Std_Dev
2.7.9.1 Float functions and macros
str
2.2.1.7.3 String Functions
strcmp
2.2.1.3.4 Functions
streams
2.1.2.7.1 Text Streams
strength
2.4.1.1 Blob
String
String Literals
2.2.1.7.1 String Literals
Strings
2.2.1.7 Strings
strlen
2.2.1.3.4 Functions
strlwr
2.2.1.7.3 String Functions
strupr
2.2.1.7.3 String Functions
sturm
2.4.9.9 Sturm
Subset_End_Frame
2.1.2.1.3 Subsets of Animation Frames
Subset_Start_Frame
2.1.2.1.3 Subsets of Animation Frames
substr
2.2.1.7.3 String Functions
sum
2.2.1.6.1 Sum and Product functions
sunpos
2.7.20.6 sunpos.inc
Supercone
2.7.12.1 shapes.inc
superellipsoid
2.4.1.11 Superquadric Ellipsoid
superquadric
2.4.1.11 Superquadric Ellipsoid
Supertorus
2.7.12.1 shapes.inc
Surface Highlights
Surfaces
switch
2.2.2.6.3 The #switch, #case, #range and #break Directives
Switches
syntax highlighting
sys
2.3.3.6 Charset
SYS file type
3.1.5.1 SYS File Type
System requirements
3.1.4 System Requirements
System-specific features
3.1.5 System Specific Features
System-specific output
2.1.2.4.1 Output File Type
t
2.2.1.4.3 Operators
tan
2.2.1.3.4 Functions
tand
2.7.9.1 Float functions and macros
tanh
2.2.1.3.4 Functions
Tapering Conic Sweeps
1.3.1.3.4 Conic Sweeps And The Tapering Effect
Targa output
target
2.6.3.2.2 Shooting Photons at an Object
Test_Abort
Test_Abort_Count
text
2.4.1.13 Text
Text Menu
3.5.4 Text Menu
text streams
2.1.2.7.1 Text Streams
Text_Space
2.7.12.1 shapes.inc
Text_Width
2.7.12.1 shapes.inc
texture
2.5 Textures
Texture Maps
Texture Options
texture-list
2.4.2.4 Mesh2
texture_list
2.5.8 Triangle Texture Interpolation
texture_map
2.5.5.1 Texture Maps
Textures
tga
2.5.1.5.1 Specifying an Image Map
The Left-Handed coordinate system
1.2.1.1 Understanding POV-Ray's Coordinate System
The scene
thickness
2.5.3.6 Iridescence
Thin-Film Interference
1.3.4.3.4 Using Iridescence
threshold
2.4.1.1 Blob
tiff
2.5.1.5.1 Specifying an Image Map
tightness
2.4.7.2 Spotlights
tile2
2.5.5.2 Tiles
Tiles
2.5.5.2 Tiles
Tiles_Ptrn
2.7.17.7 Texture and pattern macros
tolerance
2.4.1.10 Sphere Sweep
toolbar
3.4.2 The Toolbar
Toolbar Command Line
3.4.2.2 Toolbar Command Line
Tools Menu
3.5.9 Tools Menu
toroidal
2.5.12.6.5 Mapping using warps
torus
2.4.1.14 Torus
trace
2.2.1.4.5 Functions
Trademarks
3.1.8 Trademarks
transform
2.8.5 Transformations
transformations
translate
2.8.5 Transformations
transmit
2.2.1.5 Specifying Colors
Transparent Pigments
triangle
2.4.2.6 Triangle and Smooth Triangle
Triangle_Str
2.7.16 strings.inc
triangle_wave
2.5.12 Pattern Modifiers
true
2.2.1.3.5 Built-in Constants
ttf
2.4.1.13 Text
turb_depth
2.3.2.3 Fog
turbulence
2.5.12 Pattern Modifiers
type
2.4.2.1 Bicubic Patch
u
2.2.1.4.3 Operators
u_steps
2.4.2.1 Bicubic Patch
ultra_wide_angle
2.3.1.2.4 Ultra wide angle projection
undef
2.2.2.2.4 Destroying Identifiers with #undef
Union
2.4.6.2 Union
up
2.3.1.1.5 Up and Right Vectors
updating POV-Ray
3.5.8.8 Check For New Versions
use_alpha
2.5.11.20 Image Pattern
use_color
2.5.2.3.3 Use_Index and Use_Color
use_colour
2.5.2.3.3 Use_Index and Use_Color
use_index
2.5.2.3.3 Use_Index and Use_Color
user license
1.5.1 POV-Ray User License
user-defined functions
User_Abort_Command
User_Abort_Return
2.1.2.6.3 Shell Command Return Actions
Using POV-Ray for Unix
5.1 Introduction
Using POV-Ray for Windows
3.1 Introduction
utf8
2.3.3.6 Charset
uv_indices
2.4.2.4 Mesh2
uv_mapping
2.5.7 UV Mapping
uv_vectors
2.4.2.4 Mesh2
v
2.2.1.4.3 Operators
v_steps
2.4.2.1 Bicubic Patch
val
2.2.1.3.4 Functions
VAngle
2.7.9.2 Vector functions and macros
variable ior
1.4.3.4 Can I specify variable IOR for an object?
variable reflection
2.5.3.4 Specular Reflection
variance
2.3.1.3 Focal Blur
vaxis_rotate
2.2.1.4.5 Functions
VCos_Angle
2.7.9.2 Vector functions and macros
vcross
2.2.1.4.5 Functions
vCurl
2.7.9.3 Vector Analysis
VDist
2.7.9.2 Vector functions and macros
vdot
2.2.1.3.4 Functions
VDot5D
2.7.9.2 Vector functions and macros
Vector
2.2.1.4 Vector Expressions
Vectors
VEq
2.7.9.2 Vector functions and macros
VEq5D
2.7.9.2 Vector functions and macros
Verbose
Version
2.2.2.5 The #version Directive
version identfier
vertex_vectors
2.4.2.4 Mesh2
VFAQ
1.4 Questions and Tips
vGradient
2.7.9.3 Vector Analysis
Video_Mode
Vista_Buffer
vlength
2.2.1.3.4 Functions
VLength5D
2.7.9.2 Vector functions and macros
VMin
2.7.9.2 Vector functions and macros
vnormalize
2.2.1.4.5 Functions
VNormalize5D
2.7.9.2 Vector functions and macros
VPerp_Adjust
2.7.9.2 Vector functions and macros
VPerp_To_Plane
2.7.9.2 Vector functions and macros
VPerp_To_Vector
2.7.9.2 Vector functions and macros
VPow
2.7.9.2 Vector functions and macros
VPow5D
2.7.9.2 Vector functions and macros
VProject_Axis
2.7.9.2 Vector functions and macros
VProject_Plane
2.7.9.2 Vector functions and macros
VRand
2.7.11.1 Flat Distributions
VRand_In_Box
2.7.11.1 Flat Distributions
VRand_In_Obj
2.7.11.1 Flat Distributions
VRand_In_Sphere
2.7.11.1 Flat Distributions
VRand_On_Sphere
2.7.11.1 Flat Distributions
vrotate
2.2.1.4.5 Functions
VRotation
2.7.9.2 Vector functions and macros
VSqr
2.7.9.2 Vector functions and macros
vstr
2.2.1.7.3 String Functions
VStr2D
vtransform
2.7.18 transforms.inc
vturbulence
2.2.1.4.5 Functions
VWith_Len
2.7.9.2 Vector functions and macros
VZero
2.7.9.2 Vector functions and macros
VZero5D
2.7.9.2 Vector functions and macros
warning
2.2.2.7.1 Text Message Streams
Warning_Console
Warning_File
Warning_Level
warp
2.5.12 Pattern Modifiers
water_level
2.4.1.5 Height Field
WAV files
3.5.7.11 Sound Settings
waves
2.5.11.35 Waves
Wedge
2.7.12.1 shapes.inc
while
2.2.2.6.4 The #while...#end Directive
Width
2.3.2.5 Rainbow
Wire_Box_Union
2.7.12.1 shapes.inc
wood
2.5.11.36 Wood
wrinkles
2.5.11.37 Wrinkles
write
2.2.2.3.4 The #write Directive
x
2.2.1.4.3 Operators
y
2.2.1.4.3 Operators
yes
2.2.1.3.5 Built-in Constants
z
2.2.1.4.3 Operators


Copyright 2003-2004 Persistence of Vision Raytracer Pty. Ltd.