POV-Ray : Documentation : 3.5.5.15 Editor Preferences
  POV-Ray 3.6 Documentation Online View  
3.5.5.14 Color Scheme   3.5.6 Insert Menu

3.5.5.15 Editor Preferences

Before reading this section, we recommend you review Global vs. Local Options if you have not done so recently.

3.5.5.15.1 Color/Font

This property page allows setting of various editor parameters relating to the color of the syntax highlighting, page background, and font. Changes made on this page affect all editor windows immediately and are stored in the registry for recall the next time POVWIN is run.

-

Item

This list box allows you to select which item you want to set the color for. An 'item' is any individually-controllable color within the editor. For example, plain text, bookmarks, the left border, comments, and so on are all individually controllable.

See also Color Scheme.

Color

This sets the foreground color of the item selected in the 'Item' listbox.

Background

This sets the background color of the item selected in the 'Item' listbox. If it is set to 'default', then the background color will be the same as the window background.

Font

This allows you to set the font face, size, and style that is used for displaying the text within the editor windows.

3.5.5.15.2 Language/Tabs

This property page allows you to manually specify the language that the current file uses. The editor normally will set this for you, but if you are editing a supported language in a file with an unrecognized extension, you may want to manually specify it.

You can also set the auto-indentation style in use and the tab settings.

-

Auto Indentation Style

This allows you to select the auto-indentation style for the currently selected file. This style will then become the default for all newly-loaded files, but will not change the auto-indentation style for any already-loaded files. Note that the auto-indentation style selected for a file is saved in the registry, and is retained with the file in the MRU (most-recently-used) file list held in the File Menu.

Tabs

You can select the number of columns tabs expand to here. Additionally, if 'Convert tabs to spaces while typing' is checked, pressing the TAB key will not insert a hard tab but will instead insert the apppropriate number of spaces.

We strongly recommend that you use the 'Convert tabs to spaces while typing' option if you intend to use the tab key in a file that you will distribute to other users. This is because different people have different preferences for tab indentation settings, and if a person receives a file from you with hard tabs embedded in it, and has a different setting for tab expansion, your code may not align properly. This can make it hard to read.

Changing the tab expansion setting affects the current file, and also becomes the default for any newly-loaded files. It does not affect the tab expansion settings for already-loaded files.

Language

You can choose the file language here. This setting controls syntax highlighting and the indentation rules (if you have 'Follow Language Scoping' set for the Auto-indentation style).

The editor supports syntax highlighting for the following file types: POV-Ray, C/C++, Basic, Java, Pascal, SQL, HTML, and XML.

3.5.5.15.3 Keyboard

This property page allows you to set the key sequence assigned to all built-in editor commands.

-

Not all commands are assignable ! In general, only the commands that are directly implemented in the CodeMax editor DLL are able to be set. These commands are ones that relate to operations on individual edit buffers. They do not include such things as file operations (load, save, print, etc). These operations are implemented in the POVWIN editor wrapper code and are not managed or able to be changed by CodeMax. Therefore, it should be clear that you can neither change the key bindings for operations such as file save, nor use the POVWIN- assigned keystroke (e.g. Ctrl-S in the case of save) for any other purpose.

See the Default Key Mappings section for a list of all the default assignments of editor commands to keystrokes. Note that each command may have two different key sequences assigned to it, and that each key sequence may have up to two keystrokes (e.g. the old 'Wordstar'-style commands).

To assign a key to a command, choose the command you want in the listbox on the left, and then click in the box titled 'New Key Assignment' and press the key(s) you want to use, then press 'Assign' to set it.

Hint: it's very easy to just press 'OK' after typing in a new key assignment, without pressing 'Assign' first! If you do this, the new keystroke will not be assigned.

3.5.5.15.4 Misc

With the exception of 'Line Numbers', all the options on this property page affect all editors. All take effect immediately.

-

Smooth Scrolling

If checked, scrolling of the editor window will be 'smooth' rather than jerky. Some people prefer this, though it is slower than the traditional scrolling.

Show Left Margin

If checked, the left margin will be visible. The left margin is a useful area that can contain things such as line numbers and bookmark markers. It can also be colored differently from the main text. You can highlight an entire line by clicking in the left margin next to it, and highlight a range of lines by clicking and dragging in the margin.

See The Editor Window for an example of the appearance of the left margin.

Line Tooltips on Scroll

If checked, and you scroll the edit window by dragging the scroll-bar thumb, a line tooltip will show the approximate line number you have scrolled to.

Allow Drag and Drop

If checked, OLE drag and drop text editing is enabled. This allows you to highlight blocks of text and drag them to another position within the editor window, or even to another editor program that supports the same feature (e.g. the standard Windows 'wordpad' editor, Microsoft Word, and many others). Of course, you can also drag text from those applications and drop it into the editor window.
Mouse ActionResult
L-Button down over selection, and drag Moves text
Ctrl + L-Button down over selection, and drag Copies text

Allow Column Selection

If checked, columns of text can be selected with the mouse and then manipulated. Empty columns (columns with a width of zero characters) can be selected, causing subsequent typing and deletion to occur over multiple lines at the same time.

See Using the Mouse for a description of how to select columnar blocks.

Confine Caret to Text

This is the same as the Constrain Caret To Text option in the Editor Menu. Please refer to that documentation.

Color Syntax Highlighting

If checked, color syntax highlighting will be used according to the Language setting. You can control the colors used from the Color/Font Property Page.

See The Editor Window for an example of the appearance of syntax highlighting.

Show Horizontal/Vertical Scrollbar

These two options select whether the edit window has horizontal scrollbars, vertical scrollbars, or both.

Note that if you turn off a scrollbar, you lose the ability to split the window in that direction (since the window splitter for each direction is on the scrollbar). In this case, the appropriate 'Allow Splitting' option (see below) will be dimmed and unavailable.

Allow Horizontal/Vertical Splitting

These two options select whether or not you can split a window by dragging on the horizontal or vertical splitters (see The Editor Window for an example of what the splitters look like).

Using this method you can split the window into up to four different sections. Each section will still show the same file, but the sections can show different parts of the file. Editing in one section causes the changes to be immediately visible in any other sections that are showing the same part of the file.

Line Numbering

This allows you to turn on line numbering, which may be in decimal, hex, octal or binary (!). Note that this setting does not influence whether or not line numbers are included in printouts you make of the file; if you want printed line numbers, you can select that option in the print dialog.

Note that, unlike the other settings on this property page, the Line Numbers setting only applies to the current editor file. Additionally, it is not preserved across invocations of the editor; once you exit, the setting is forgotten.

Max Undoable Actions

Allows you to set a limit on the number of edit actions that will be stored in the 'undo' buffer. Actions older than this limit will be discarded. Unless you are critically low on memory (or don't like having hundreds of undo's available), we recommend that you leave this on the default setting of 'infinite'.

More about "File Menu"

More about "Language"

3.5.5.14 Color Scheme   3.5.6 Insert Menu


Copyright 2003-2004 Persistence of Vision Raytracer Pty. Ltd.