POV-Ray : Documentation : 3.5.8.10 Other Settings
  POV-Ray 3.6 Documentation Online View  
3.5.8.9 Include System Information   3.5.9 Tools Menu

3.5.8.10 Other Settings

This sub-menu contains a number of less-commonly-used options so as to reduce clutter in the main options menu.

-

3.5.8.10.1 Use Editor

Turns the use of the internal editor on or off.

3.5.8.10.2 Show Tips of the Day

This command lets you decide whether you want POV-Ray for Windows to display the tip of the day on startup. By default, POV-Ray for Windows displays a new tip every time the program is started more than 24 hours after the previous tip was shown. Selecting Show Tips of the Day has the same effect as selecting the 'Show tip tomorrow' box in the tip screen.

3.5.8.10.3 Show Tooltips

Turns Tooltips on or off. A Tooltip is a little yellow window that will pop up over a toolbar button if you keep the cursor there for long enough. The tip window tells you what the button does.

3.5.8.10.4 Preserve Messages

Whenever you perform a render, POV-Ray for Windows generates a number of messages (active POV-Ray settings, rendering statistics etc.) in the POV-Ray window. If you select Preserve Messages, POV-Ray for Windows retains all messages generated during the current session. If you deselect this option, all existing messages are deleted every time you perform a new render. See also Clear Messages in the Edit Menu.

N.B. Don't forget that the statistics for each completed render are available from the Rerun Dialog.

3.5.8.10.5 Save Settings on Exit

If you select this option, any settings you have selected during your current POV-Ray for Windows session will be stored for the next one. These include the position and size of the Main Window as well the position of the Render Window.

3.5.8.10.6 Hide New User Help

Selecting this option will cause the 'Help On This Menu' entries to be removed from all menus. We recommend you do this once you're an experienced user.

3.5.8.10.7 Show Next Tip

If you do not want to see the tip of the day pop up automatically on startup every day, you can still see a tip whenever you feel like it. If you select Show Next Tip, POV-Ray for Windows displays a single tip but keeps the 'Show tip tomorrow' box unchecked.

3.5.8.10.8 Re-Render Insert Menu Bitmaps

The preview bitmaps distributed with the POV-Ray for Windows insert menu are of a fairly small size in order to keep the size of the distributed setup file down. However, it is easy to re-render them all at a larger size (though it may take a while on a slower computer).

Just select the 'Re-Render Insert Menu Bitmaps' option and leave POV-Ray for Windows running. Eventually all the bitmaps will be replaced with larger ones.

3.5.8.10.9 Message Window

This sub-menu allows you to set certain properties of the message window.

-

3.5.8.10.10 Select Plain Background

POV-Ray for Windows comes with a bitmapped background as default. If you prefer a plain background, you can select this command. The background takes on the currently defined background color (see Background Color below).

3.5.8.10.11 Text Font

Use this command to determine the font POV-Ray for Windows uses to display messages and statistics. In addition to the type of (non-proportional) font, you can set font size and appearance. POV-Ray for Windows remembers the font setting between sessions.

Note: If you select italic text, this setting will not be preserved across invocations of POV-Ray.

3.5.8.10.12 Text Color

This command lets you determine which text color best fits the background you have selected for the Main Window.

3.5.8.10.13 Background Color

This command lets you select the color of the plain background for the Main Window. Note that this command has no effect while you have tiled the background with a bitmap. The color only becomes visible when you select Plain Background (see above).

3.5.8.10.14 Tiling Options

You can change the tiled bitmap POV-Ray for Windows displays in its message window. Choosing Tiling Options brings up a sub-menu where you can select one of several built-in bitmaps. You can also browse your disk for other bitmaps you might prefer. POV-Ray for Windows pre-installs a number of them in the TILES subdirectory of your POV-Ray for Windows home directory. The bitmaps should have no more than 256 colors. If the BMP file you select is smaller than the Main Window, it will be tiled. If it is larger, POV-Ray for Windows fits it into the top-left corner of the Main Window and displays as much of it as the Main Window allows.

Note that because of the POV-Ray for Windows generalized palette, if you are running in 256-color mode, external bitmaps may not tile 100% perfectly, and the colors may be slightly altered. If you are running in 16-color mode, tiled backgrounds are not available at all. In practice, choosing tileable bitmaps other than the standard Marble one, using a 256-color display, will often not yield attractive results.

3.5.8.10.15 Render Window

This sub-menu allows you to set certain properties of the render window.

-

3.5.8.10.16 Force 8 Bit Display

POV-Ray for Windows is capable of displaying a rendering scene in 24-bit color (Truecolor). This takes up a great deal of RAM, however: 3 bytes for every pixel in the rendered scene. If you do not have enough RAM to spare, you should select this option. It forces POV-Ray for Windows to display the scene in 8-bit color (1 byte per pixel) and to use color dithering to represent the rendered image on the screen. If you are already using a 256-color video mode it does not make any difference since the image is already stored as one byte per pixel. Note that this does not change the way that the rendered image is stored on disk. If you are writing an output file, the file will still be 24-bit color!

In 15 or 16 bit color modes, the image is stored in memory as 24-bit but only displayed as 15 or 16 bit. No dithering is (currently) performed in these modes.

3.5.8.10.17 Preserve Contents During Animation

If this option is enabled (the default) and you are rendering an animation, the contents of the render window (which shows the previous frame of the animation) are not erased prior to a new frame being started. This makes it easier to see subtle changes in the image output (such as a small object moving from frame to frame, while the rest of the image stays static).

Note that the render window contents are always erased prior to the first frame, regardless of the setting of this option.

3.5.8.10.18 Re-display

If the Render Window is closed (see Close below), you can re-display it by selecting this command. If the window is not closed in the first place (or has never been displayed), you cannot re-display it, and so the Re-display command is grayed.

Note that this command is also available on the toolbar.

3.5.8.10.19 Autoclose

This causes the Render window to close automatically when rendering is complete. This is particularly useful if you're doing quick test renders at low resolution.

3.5.8.10.20 Close

This command closes the Render Window. This does not interfere with any rendering activity. Indeed, it speeds up rendering (see also Speed Considerations). To re-display the Render Window, select Re-display, use the right-mouse button speed menu on the message window, or simply click the 'Show' toolbar button.

Note that this command is also available on the toolbar.

3.5.8.10.21 Keep Above Main

If you make the POV-Ray for Windows Main Window active with Keep Above Main deselected, the rendering window may still be obscured by the main or any other window. Selecting Keep Above Main ensures that the rendering window pops up from under other windows whenever you make POV-Ray for Windows active. Note that if this option is set, you cannot hide the render window behind the main window (this can be a problem if you are rendering at the same time you are editing; hence the ability to set both modes via this option).

Note: if you enable this option, the 'Get Focus on Creation' and 'Hide When Main Minimized' options detailed below will be grayed out.

3.5.8.10.22 Get Focus on Creation

This command causes the POV-Ray window to get focus (pop to the foreground and become active) whenever a new file is processed. If POV-Ray for Windows is processing a file queue or animation, the POV-Ray Main Window gets focus every time a new file is initialized from the top of the queue, or a new pass over the animation source file is performed. This only applies, of course, if you are using the render window.

If you want to do other work on your Windows machine while POV-Ray is rendering, but you have the render window displayed, you will probably want to have this option off since otherwise the window will keep on popping up over whatever you are doing, each time a new image is rendered.

Hint: A handy shortcut to remember is that hitting the Escape key when the render window gets focus will return focus to the main window. This is particularly useful after a quick test render.

Note: if the 'Keep Above Main' option documented above is enabled, this option will be greyed out. This is because 'Keep Above Main' implies 'Get Focus On Creation'. If you don't want the render window to get focus on creation, you will need to turn 'Keep Above Main' off.

3.5.8.10.23 Hide When Main Minimized

If you have 'Keep Above Main' turned off, the main POV-Ray window and the Render Window are no longer linked. You now have the option of continuing to show the Render Window whenever the Main Window is minimized. If you select this option, the Render Window disappears as soon as you minimize the Main Window.

Note: if the 'Keep Above Main' option documented above is enabled, this option will be greyed out. This is because 'Keep Above Main' implies 'Hide When Main Minimized'. If you don't want the render window to be hidden when the main window is minimized, you will need to turn 'Keep Above Main' off.

3.5.8.10.24 Editor Window

This sub-menu is identical to the main Editor Menu. It is included in the Options Menu for consistency.

More about "Edit Menu"

More about "Speed Considerations"

3.5.8.9 Include System Information   3.5.9 Tools Menu


Copyright 2003-2004 Persistence of Vision Raytracer Pty. Ltd.